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1 Introduction
Once upon a time there was the printing press. If you wanted to print something, you wrote it by hand or
with a typewriter, then posted it to your publishers. You didn’t worry about what your manuscript would
look like when it was printed; you trusted them to make sure that it would look good. Then word processors
came along. Suddenly, you could print things yourself, and decide exactly how they would look. However,
this freedom came at a price, and we now spend almost as much time formatting our documents as we do
writing the damned things. LYX is the answer to this problem; you tell it what to do, and it decides how
it will look on the page, leaving you free to concentrate on actually writing words, rather than messing
around with tabs and font sizes.
This is a simple introduction to using LYX, written mainly for students and academic staff. LYX is ideal
for academic writing, since that was largely what it was designed for. Much of this guide is adapted from
the official LYX Tutorial and User Guide, which I thoroughly recommend reading later1 . References to
menus etc. are based on LYX version 1.1.6; previous versions are the same in most ways, but a few features
are under different menus or absent.

1.1 When to use LYX
LYX is not for everybody, or for all purposes. Use LYX if:
You want printed output that looks professional and aesthetically pleasing;
You hate all those fiddly things that you need to keep doing with word processors, like tabbing, extra
spaces, margin and font size adjustments etc.
Do not use LYX if:
You need complete control over your layout and formatting, e.g. exactly how many cm. a line is
indented, or exactly where a figure appears. This is actually rarer than you might think2.
1 You

can find them, and other documentation, under the Help menu.
is possible to specify these things precisely in LYX, but it is hardly ever worth the effort; LYX will normally format everything
nicely for you anyway.
2 It
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You are addicted to fancy fonts and table formats. LYX uses a fairly limited range of fonts, and
produces rather plain, serious-looking tables3 . There again, look at any real book. Does it have half
a dozen different fonts? Does it have tables with embossed borders and shading? Believe me, you
can learn to do without these things.
You need seamless compatibility with other word processors or office programs like spreadsheets.
LYX can import and export documents in a variety of formats, but it will not give you the same degree
of integration as an office suite.

1.2 How to get LYX
If you don’t already have LYX installed on your computer, you can download it from www.lyx.org . This
site has the latest version as a tar.gz file, but you will probably prefer to download a version specific to your
system; links are provided for RPM’s in various Linux flavours and a Windows version.
LYX is a front-end for a lot of other software. Some of this is absolutely essential, such as TEX and
LATEX; other programs do useful things which won’t be available if you don’t have them (e.g. latex2html or
a similar converter is necessary if you want LYX to be able to write HTML documents). If you have a reasonably new version of Linux/Unix on your computer, you should already have all the essential packages;
Windows users will need to install quite a few things. As far as I know there is no version of LYX for the
Macintosh.
If you are using a computer in a university lab, LYX may be installed anyway. If not, ask your system
administrator to install it; any decent university system will have TEX and LATEX, so adding the LYX program
on top of it should be no problem.

1.3 Things to get straight before you start.
The most important thing to remember is that LYX is not really a word processor (even though it is sometimes described as a “high-level word processor”)4. A word processor is just a clever typewriter; it simply
translates key-strokes into pixels on a screen instead of ink on paper. LYX is more like conventional publishing, where you give the publisher a type-written manuscript and tell them what formatting you want, or
leave them to make up their own minds.
This means that in LYX, what you see is not what you get. What you see is what you mean (to see what
you will eventually get, you use a previewer - more of that later). This can be a little confusing if you are
used to word processors, since many of the tricks you use for formatting, like tabbing or hitting the space
bar twice after a full stop, do not work in LYX. This is because LYX does all of that for you.
The moral here is to forget what things will look like on the page. Just type what you want and let the
computer sort out the rest. There are ways to make it format in particular ways, but 99% of the time you
won’t need to do anything more than the following:
1. Tell the computer what type of paragraph you are writing (unless it’s just plain text, which is the
default). For example, you can tell it to write a subsection heading, a numbered or bulletted list, or
an indented quotation.
2. Add any formatting for individual words, like italics, SMALL

CAPITALS

or bold.

2 A Simple LYX Tutorial
This tutorial is hands-on – it works best if you actually do all the things suggested. Believe me, a small
amount of time spent learning the basics will save you hours later. LYX is very simple, and much easier to
3 Again, there are ways to install different fonts and mess around with tables, but if you can do this kind of thing, this guide is way
below your level - just get a good book on LATEX!
4 To be precise, L X is a “document processor” or high-level typesetting program; it writes commands which are interpreted in
Y
LATEX, which is a set of macros for TEX, which is a typesetting language. These are converted to DVI (a printing language) and finally
output in PostScript. Fortunately, you don’t need to bother about all this.
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use than a conventional word processor, but it can sometimes be very different from what you are probably
used to. On the other hand, a lot of operations will already be familiar.

2.1 Basic operations
Most of the basic operations like opening and saving files, or getting around inside them, are the same as
just about any word processor.
2.1.1 Creating a document
First, open LYX by clicking the icon, going through the Start menu or opening a terminal and typing lyx.
Here’s the first weird thing: unless you’re using KLYX, there is no familiar blank page icon to open a new
document. Instead, click on the “Open” icon (you can also go to the File menu and select New, but why
bother?). Go on, do it now. This is a tutorial, not a manual, so it won’t work if you don’t do it.
What comes up is your home directory. If you used New, your file will be called, predictably, “newfile”;
otherwise the space will be blank. In either case, give it a name and click OK.
What you now see is a screen with the top line highlighted in whatever colour your desktop has decided,
and then the rest in some other colour (usually white). Type a load of rubbish. You will see the highlighted
colour expand to keep up with your typing. Hit Return, keep typing, and you will get another paragraph,
just like you would expect. Note that it indents the next paragraph automatically. Do this for a while, so
you’ve got a fair amount of text to play with. Now for the strange part. Hit Return again. And again. As
you can see, nothing happens. This is because Return means “here’s a new paragraph”, not “go down one
space”. If you don’t start another paragraph, the computer will ignore you.
Don’t worry. LYX has already decided how much space is necessary between paragraphs, so you don’t
need to do anything. But let’s suppose you really do want a blank line. A quick fix is to hit Return again,
hit Ctrl-Space, then hit Return again. You’ll see a tiny pink squiggle, which is the sign for a “protected
space”; when you print out, this will not appear - you just get a blank space (there are more sophisticated
ways to adjust spacing between text as well). This is what happens when I do that:
You can also use Ctrl-Space to insert extra spaces between words like
this. Normally you don’t
need to do this, since LYX automatically works out the best spacing between words, and if you repeatedly
hit the Space key without the Ctrl, it does absolutely nothing (as you’ve probably guessed, Space means
“here’s a new word”, not “print a blank space”).
Save your document as you would in any other program, i.e. by clicking the floppy disk icon at the top,
or going to the File menu and choosing Save (if you’re a hot-key demon, you can also hit Ctrl-S).
2.1.2 Navigation and Editing
The navigation and editing controls are the same as any word processor. Move around with the mouse, or
by using the following hot-keys:
Home / End goes to the beginning/end of the line;
Ctrl-Home / Ctrl-End goes to the beginning/end of the document;
Ctrl-





/ Ctrl- 

goes to the beginning/end of the current word;

Ctrl- / Ctrl- goes to the beginning of the next/previous paragraph.
Ctrl-Delete deletes to the end of the word
Ctrl-Backspace deletes to the beginning of the word
Ctrl-Z undoes the last action

As with all word processors, holding down Shift when you do any of these blocks (highlights) the text, e.g.
Ctrl-Shift-End will block everything from the cursor position to the end of the document.
Cutting, copying and pasting are exactly the same as a normal word processor; use the icons or the
standard hot-keys:
3

Ctrl-X

cut;

Ctrl-C

copy;

Ctrl-V

paste.

The Backspace, Delete, Page Up and Page Down keys all work as you would expect. The Tab key does not
tab (because
LYX handles tabbing itself) but takes you to the beginning of the next paragraph (the same as

Ctrl- ).
2.1.3 Viewing and Printing
You can print your document just by clicking the printer icon, but you may want to see what it looks like
first. You have a number of choices here, depending on the format you eventually want for your document;
assuming you are just writing something that you want to print out, Postscript is probably the best (DVI is
quicker, but Postscript is a more accurate view of what the document will really look like). Go to the View
menu and choose Postscript (or just type Ctrl-T)5. This actually opens another program which displays your
document as it will look when printed. Keep this open if you haven’t finished your document yet.
If you now go back to your LYX file and carry on typing, the preview will not change. To see the
changes, go to View as before, then choose Update and Postscript. Now go to your previewer and click
the “reload” or “redisplay” icon (different previewers work differently; the previewer is not part of LYX,
but will be the one your computer normally uses). With some previewers, you can also set them to update
automatically; in Ghostview (the most common previewer) go to the State menu and choose Watch file. It’s
actually a bad habit to keep doing this, though; the golden rule in using LYX effectively is to concentrate
on what you want to write, not what it is going to look like, so the previewer is normally only useful for
final checking.
Having seen the look of your document, you may at this point want to change some of the LYX defaults
to produce the kind of printed output which you want. First check the paper size by going to Layout and
selecting Document, then clicking on Paper. Click on Special and choose A4 very small margins (unless
you like big margins, of course). Before you click close, you may also want to change a few other things.
For example, if you want to make the default font size a little larger; click the Document tab and change
Font size to 11 or 12 (note that you only need to change the default size; all other fonts are adjusted relative
to this). You can also change the font face, e.g. to Palatino, though as I said, your options are rather limited
here. If you prefer your paragraphs to be separated by a blank line, click on Skip (on the right). Finally,
if you don’t want your pages to be numbered, change Pagestyle from Default to Empty. If these are the
settings you want for most of your writing, go to Layout once more, and select Save Layout as default.
Print your document with the printer icon from either LYX or the previewer; assuming that your main
file and your preview are in sync, it should make no difference.

2.2 Basic formatting
LYX is designed so that you spend as little time as possible on the formatting of your document, leaving you
free to concentrate on what you actually want to write. To this aim, it uses three main levels of formatting:
document classes, paragraph environments and character styles.
2.2.1 Document classes
A document class determines the other formats which are available, but for the most part, you don’t need
this feature. The default is “Article”, which is fine for most things, but you may also want to experiment
with other classes later. For example, there are variations on the “Article” class (e.g. “Article (AMS)” )
which lay out section headings in different ways, and a number of different classes for letters etc.. Later,
you may consider downloading other classes, or maybe even create your own.
5 In

older versions of LYX, go to the File menu first; in KLYX, go to the Preview submenu first.
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Or
Layout
->
Paper,
in
older
versions of
LYX.

2.2.2 Paragraph environments
This is the important bit. Paragraph environments are rather like styles in conventional word processors,
and they are the key to formatting with LYX. What you have at the moment is all in the “Standard”
environment, i.e. plain text. You’ll see the word “Standard” in the box in the top left corner.
Now click the mouse somewhere in your document, then click the downward arrow in the
box, and choose “Quotation”. The paragraph that you clicked on has now been changed into a
block quote, like this paragraph. If you prefer the first line not to be indented, choose “Quote”
instead of quotation.
By using paragraph environments, you can get just about any formatting you want. For example, to get the
subheading for this section using Microsoft Word, I would (unless there was a suitable style defined) have
to do the following:
1. Type “2.2.2 Paragraph Environments” (remembering to hit Space twice after the number);
2. Block it, bold it and increase the font size;
3. Go to Format then Paragraph, then select a 6pt space at the end;
4. Hit Return and make sure everything was back to normal.
What I did to get the same effect in LYX was simply
1. Select the “Sub-subsection” environment;
2. Type “Paragraph environments” (no need for the number);
3. Hit Return.
In this case, I did not even need to re-select the “Standard” environment, since it will normally revert to
this after headings6.
The most useful environments are as follows:
Part, Section, Subsection, Subsubsection
Produce numbered parts, sections etc. The numbering is done automatically. All these revert to “Standard”
after hitting Return.
Part*, Section*, Subsection*, Subsubsection*
The same, but without the numbers. The line above this one is in the “Subsubsection*” environment, and I
used “Part*” for the title. These also revert to “Standard”.
Enumerate
1. This produces numbered lists.
2. It does not revert to “Standard” when you finish.
3. Therefore, you need to select “Standard” again to break out of the list.
6 In other words, not counting typing “Paragraph Environments”, I used 6 keystrokes and 7 mouse-clicks in Word, and 1 keystroke
and 1 mouse-click in LYX! To be fair to Word and other word processors, there are things you can do to set up pre-defined styles,
numbering etc. I did this when I was typing my MA dissertation; unfortunately it took longer to get it working properly than it would
have done to have typed everything manually, and when I came back from holiday, someone had deleted all my custom styles.
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Itemize
Ditto for bulletted lists.
Like this.
Quotation, Quote
Both of these produce block quotes.
“Quotation” produces indented paragraphs (as in the above example). It is best used for
longer quotations, like this. Blah blah blahdeblah blah blah blah blahblahblah blahdeblah
blah blah blahblahblah blah blah blah blahdeblah blah blah blahblah blahdeblah blah blah
blahblahblah.
Blahdeblah blahblah blah blahdeblah blahblah blah blah blahblah blah blahblahblah blah
blah blahblahblah blahdeblah blah.

“Quote” does not indent, but leaves a space between paragraphs.
Like this.

Again, these environments do not revert to “Standard”.
List
This leaves a space after the first word of each line. It is therefore good for producing lists of definitions
like this:
CPU

Central Processing Unit, the chip at the heart of your computer.

CPH

The number of times Windows crashes per hour.

Gates, Bill Head of the Microsoft Evil Empire.
Note that to get the space coming after “Bill” rather than “Gates”, I had to use Ctrl-Space rather than a
normal space after the comma. “List” tries to align the entries after the space as much as possible, but
entries after long initial words (like the last one) may come further to the right (which is probably better
than having to have all entries way over to the right because of one long one).
“List” does not revert to “Standard”.

Play around with the above environments, and any others that look interesting.
For example, this paragraph is in “LyX-Code”, which simulates a fairly dumb
word processor with a typewriter font.
Note that the “Comment” environment
shows up only in LyX, not in the printed or previewed output. “LaTeX” is one
you don’t want to mess with yet - it breaks out of LyX mode so as to write
raw LaTeX commands.
NOTE : The “Title” paragraph environment can be used for titles (not surprisingly) but it has the annoying
feature of automatically inserting the date as well. There is a way round this, which is to set the next
paragraph as “Date” and type Ctrl-Space, but it’s not usually worth the hassle - “Part*” works fine for most
purposes.
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2.2.3 Character styles
Click on any word in your document, then click the exclamation mark icon - the whole word will be
changed to italics (you do not need to block it). This is the emphasis style, which in most setups comes out
as italics (though there are ways to change this). Click the icon again to make the word return to normal.
Now click the icon with the little man. The word will change to NOUN STYLE , i.e. small capitals (using
S HIFT with noun style produces a big capital).
If you don’t want to change the whole word, just block the letters you want, to get effects like “uninteresting”.
Of course you can also set the style as you type; just click the icon when you want to start writing in italics
or small capitals, and click it again when you want to stop, just like a normal word processor.
You may be wondering where the bold icon is. There isn’t one, largely because bold is not commonly
used for emphasis in publishing, but is normally reserved for headings. You can bold things, though, by
going to the Layout menu, and choosing Bold Style, or using hot-keys. Personally, I hardly ever bother;
using bold for emphasis is an ugly side-effect of word processor use.
All these styles (and many others) have hot-keys:
Ctrl-E
Alt-C, C

Emphasis
7

N OUN

Ctrl-B

Bold

Ctrl-U

Underline

2.3 Clever formatting
You know have the knowledge to do 95% of what you will want to do in LYX; the rest is for fine tuning
and out-of-the-ordinary formats.
2.3.1 Tables and boxes
Find a suitable space in your document and click the “Insert table” icon (the grid near the right) or alternatively go to the Insert menu and choose Tabular. You will get a dialogue box asking you to specify the
number of rows and columns. With the mouse, move the sliders to give three rows and four columns, then
click OK. You will get an empty table like this:

Fill some of the cells with stuff, using the arrow keys to move between them, so you get something like
this:
ddakjnc
ds

asdc

sadc
adsc

asdc
adc
dsca

Note that you do not have to worry about the width of cells or placement of the table; all this is done
automatically. To get out of the table, go to the bottom right cell and hit Return. This will take you back to
the “Standard” environment.
You will have noticed that the top row is set apart from the rest, the standard way to indicate column
headings in academic publications. If you don’t want this effect, right-click anywhere on the top row. The
“Tabular Layout” box will appear. Click on the Column/Row tab, and uncheck the Bottom button. Your
table will change to this:
7 Alt-K,

in some versions of LYX.
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ddakjnc
ds

asdc

sadc

mn

adsc

asdc
adc
dsca

You can also get a table with no lines, like this:
ddakjnc
dfgd
vcx

ds
dfss
xvcb

fds
adsc
jhmmmn

adc
dsca
bn

Just drag the mouse to highlight the whole table, right-click and select Unset borders (in older versions
of LYX, you may need to click on each row individually).
You can use the table formatting buttons to get various effects, e.g.
ddakjnc asdc sadc asdc
ds
adc
mn adsc dsca
Play around and see what you get. NOTE: KLYX handles tables rather differently; once you insert a
table, a toolbar comes up with various icons for the different things you can do to it.
If you want a simple box, the best thing to do is to insert a table with only one line and one column,
then type in your text like this8 :
dsfe dfjn sdfnj sdfknj sdfknj
If you want to make boxes for a number of equally-spaced items, you can use Ctrl-Space between them,
for example:
frumious bandersnatch brillig slithy
jabberwok tove momerath gallumph
This was produced by creating a table with two rows and one column, then removing the lines between
the rows. There are fancier things to do with boxes, tables and pictures, which will be looked at in the next
section.
2.3.2 Footnotes
This is easy. Click on the footnote icon (the leftmost of the icons with a load of lines), choose Footnote
from the Insert menu, or hit Alt-I, F. A box will appear with a red “foot” in the left corner - type what you
want inside it, then use the right arrow key to get out of the box. In LYX, it will stay there (you can close
the box by clicking on the “foot”) but in the preview or printed output, it will appear at the bottom of the
page.
You can also do margin notes, though it’s hard to think when these would be useful.
2.3.3 Changing fonts
We’ve already seen how you can change the default font – note that this will not change the way things
look in LYX, only in the preview and printout; in LYX, a Roman typeface means “whatever the default font
is.”
You can also change the font temporarily. Block the text you want to change, then go to Layout, then
Character (or hit Alt-L, C). From there, you can change the family (e.g. Sans Serif) or the size (e.g. small,
smaller, larger etc.). The other features can be changed more easily using icons or hot-keys.
A nice feature is that the program remembers the last time you altered the font settings. If you want
the same custom font again, click the “Toggle on all of these” button in the character layout dialogue box.
Next time you want to put a word in that font, just hit the Font button and it will change the text to that
8

There are also ways to do this using raw LATEX commands, but this is outside the scope of this guide.
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Here’s a
margin note!

(This is how I got the menu and keyboard commands to come out in Sans Serif - I didn’t need to reset it
every time).
2.3.4 Columns
You can create documents in two columns from the Layout-Document menu. It is also possible to have
documents with three or more columns, or with only part of the document in columns, but it’s not usually
worth the trouble (the really curious can find out in the next chapter).
2.3.5 Nesting
This is a complicated subject which refers not to the desire of people in their late twenties to make a home
and start a family, but to embedding one paragraph environment inside another. For the most part, you
won’t need this feature. However, you may want to produce something like the following:
1. Bill Gates is a

.

(a) genius

NOTE :
No
tabs
were
used in this
example!

(b) charlatan
(c) devil incarnate.
To do this, first choose the “Enumerate” environment, to get your number. The answers are “nested” inside
that paragraph, and to do this, click the “Change Environment Depth” icon (third from the right) or hit Alt-P,
 . You need to do this for each nested paragraph (or if you prefer, you can block a number of paragraphs
and indent them all at once). The “Enumerate” paragraph environment gives various layers of nesting: the
outer uses normal Arabic numerals, the second has letters in parentheses, and so forth. The potential of
nesting is great but not normally necessary; read the LYX User’s Guide for more information.
2.3.6 Fill in the blanks
To get the “blank” effect in the previous example, use Ctrl-U to switch on the underline, and Ctrl-Space
to type in the required number of spaces. Don’t forget to hit Ctrl-U again for the next word to switch the
underlining off.

3 LYX Tricks
This part deals with extra features of LYX and LATEX which are rarely necessary, but can be kind of fun.

3.1 Horizontal fills
If you want to space things evenly in a line, use the Horizontal Fill command. Let’s say you want one bit
of text on the left and the other on the right. Type your first text, then go to the Insert menu and choose
Special Character, then HFill, or type Alt-I,S,H. Then type the other bit of text. The result is like this:
Text on the left

Text on the right.

You can do this with several bits of text, inserting a horizontal fill between each one, e.g.
Text on the left
More text on the left

Text in the middle
More text in the middle
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Text on the right.
More text on the right.

3.2 Maths and symbols
Since LATEX was designed with academic publishing in mind, it is not surprising that it is very good at
producing mathematical formulae like this9 :
f  x 

log8 x
0
∑5i 1 αi 



x 0
x 0
1
x

x 0

This may not be the kind of thing you’ll want to do, but the math mode does have its uses. For example,
I used it to get the arrow symbols in the section on navigation hot-keys. Different versions of LYX handle
maths differently; in 1.1.6 you go to Edit then Math Panel. The different boxes at the bottom will give
you a selection of interesting symbols. See the User’s Guide (click Help) for more detailed information on
maths.

3.3 Inserting figures
LYX has various things you can do with figures (pictures, tables etc.) in a document; here I’ll only deal
with the simplest.
One drawback is that at the moment LYX can only handle images in Postcript (or Encapsulated Postscript)
format, so to get your image into LYX, you first need to make sure it is in that format. The normal way to
do this is to open it in a graphics program which can load and save in different programs (e.g. The GIMP,
Electric Eyes or Photoshop) then do “Save as” choosing Postscript (.ps) format10 . Once you have your image in Postscript or Encapsulated Postscript format, go to the Insert menu and choose Figure. A dialogue
box will appear asking you choose between Encapsulated Postscript or Inlined Postscript; the former will
give you a normal figure separate from your text, while the latter will include the figure in the line of text

11 . You will then get another box which allows you
you are writing at the moment, like this:
to choose your file (use the Browse button) and also determine the width and height (I usually choose 90%
of column width). You don’t need to set both width and height; normally you would select the one you
want and leave the other as “default”. NOTE: the size of the figure in LYX is not an accurate indication of
the size in the final document, use the previewer if you want to check (remember LYX is not WYSIWYG!).
Click OK and you have your figure. Any time you want to change things, clicking on the figure will bring
up the dialogue box again.
Inserting figures can sometimes mess up your layout, so if you aren’t particular about exactly where a
figure should appear, an alternative to the previous method is to go to Insert again, but choose Floats, then
Figure Float. You will get a footnote-type box with the word Figure; type the title of your figure after (if
you want one) then go through the normal process of inserting a figure. LYX will now work out the most
appropriate place on the page for the figure to go. It will appear automatically numbered (you won’t see
the number in LYX, but it will appear in the printed or previewed output). You can also do clever things
with referencing floats, but that is beyond the scope of this guide.

3.4 Floating tables
You can make tables float just like figures. Do it in the same way, just choose Figure float rather than Table
float. The Wide figure float alternative is useful if you have a wide table (surprise!) that you want to wrap
so that it will fit on the page.
9

Example taken from the LYX Tutorial by Amir Karger and the LYX team (because I don’t know anything about mathematics!).
is due to change; pretty soon, LYX should be able to handle images in other formats. There are also some commands you
can use in a terminal; for example, if you have a GIF image, you can use the program gif2ps by opening a terminal and typing gif2ps
myimage.gif
11 Foot logo adapted from the GNOME start icon using The GIMP.
10 This
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3.5 Page breaks
LYX is generally pretty good at deciding when to put in page breaks, but occasionally you may want to put
one in yourself. From the Layout menu, choose Paragraph, then click on Above or Below under Pagebreaks.
Only do this when you’ve finished writing your document, though, otherwise you will end up having to do
a lot of extra fiddling.
From the same dialogue box, you can also put horizontal lines above or below paragraphs, like this.

3.6 Extra paragraph options
Normally if you want an indented paragraph, you use the “Quote” or “Quotation” paragraph environment.
However, you may sometimes want to indent more. To do this, go to the Layout-Paragraph menu and
selected Extra. From there, check the Indented Paragraph box and set the indentation length, either in
centimetres or as a percentage of the page width.
The result is a paragraph like this. Blah blah blahdeblah blah blah blah blahblahblah blahdeblah blah blah blahblahblah blah blah blah blahdeblah blah blah blahblah
blahdeblah blah blah blahblahblah.
Note that only the left margin changes, unlike the “Quote” or “Quotation” environments.
Sometimes you want to create bits of
text that are outside the normal page layout. To do this, we use “minipages”. You
can do this by going to Layout, then Paragraph, and clicking the Extra tab. Select
Minipage and choose the width and alignment you want. This paragraph is an example.
You can do a lot of clever things with minipages, but be careful. If a minipage is too big to fit on the
actual page, it will not wrap round to the next page – you just lose part of your minipage.
The other thing you can choose from the Extra dialogue is the confusingly named floatflt. This causes
the text of the paragraph to run round figures or other floating objects you have inserted into your text.
Create a floating figure as normal, then place the cursor immediately to the left of the actual figure. From
the Extra dialogue, select floatflt.

3.7 Contents page
LYX can easily generate a table of contents for you. Go to the Insert menu and select Lists&TOC, then Table
of Contents. What comes up on the screen is just a button with “Table of Contents” on it; the actual content
will come out in the preview.
Now click on the button. What comes up is the document structure, which shows what will eventually
go on the contents page. Now, you may not always want every little subheading to come up on the contents
page. Go to the Layout menu, choose Document, click on the Extra tab and adjust the “Table of contents
depth” using the arrows (e.g. “2” gives you sections and subsections, but not sub-subsections).

3.8 Import-Export
In series like Miami Vice, a dead giveaway for a drug dealer or undercover cop was that, when asked what
he did, he would reply “Oh, import, export.” However, “import” here means taking a file in some other
format and putting it into LYX, and “export” means saving a LYX document in some other format. What
you can do in LYX depends on what other software you have in your computer; for example, you can import
Microsoft Word documents if you have a recent version of WVware installed.
LYX can produce files in LATEX, plain text (ASCII), Postscript, PDF and, most importantly, HTML.
If you want to put a document you have written in LYX on your website, all you need to do is go to
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the File menu, then select Export and HTML. This will give you pretty good HTML (unlike, for example
MS Word’s “Save as HTML” function, which produces garbage that can only be understood by, surprise,
surprise, Internet Explorer). The only things you may need to adjust are features like background colour12.

3.9 The dark art of LATEX
LYX is basically a user-friendly interface to LATEX, which is a set of macros for TEX, which is a typesetting
language. Before LYX was invented, people used to write whole documents in raw LATEX, a bit like purist
web designers write web pages in raw HTML. Documents consequently used to look something like this:
\documentstyle{article}
\begin{document}
This way of writing documents is incredibly tedious for the following reasons:
\begin{enumerate}
\item You have to memorise loads of commands
\item You have to do a lot more typing
\item It’s \em{very} easy to make mistakes
\end{enumerate}

Well obviously you don’t want to have to do all that, and in LYX you don’t have to. However, when you
want to do odd things that aren’t provided by LYX, you have the option to insert bits of raw LATEX. This is
outside the scope of a beginners’ guide, but just as an example, here’s one thing you can do.
As I said before, LYX normally only gives you the option to have the whole document in two columns
or none of it. However, you can do more, if you’re prepared to roll up your sleeves and do some LATEX
hacking13.
First go to Layout and select Latex Preamble. In the box that comes up, type \usepackage{multicol}.
Now, at the point that you want to go into columns, type \begin{multicols}{2} (or {3}, or however
many columns you want). Don’t leave any spaces between the bits. Set the paragraph environment as
Latex. When you want to stop the columns, do the same thing, but with \end{multicols}.
If you want to get really clever, you can set the distance between the columns or even put a line down
the middle. To set the distance to, say, 2 cm., type \setlength{\columnsep}{2cm}. To draw a line 1
point wide down the middle, type \setlength{\columnseprule}{1pt}. Now type the multicols command as
before. The whole thing might look like this
\setlength{\columnsep}{2cm}\setlength{\columnseprule}{1pt}\begin{multicols}{2}
and the output would look like this:
This leads to the idea that a desire to learn
about nuclear physics or to help one’s neighbour, for example, is somehow peripheral to
the category of desire, and hence “weaker”,
“higher” or “sublimated”, depending on one’s
perspective. Whether in fact the desire for
knowledge is a sublimation of the desire for
food or sex is, I would argue, inconsequential.
If a person desires knowledge more than food,
they will go hungry in order to study (at least
up to a point), and the reason why they do so

is not of vital importance to philosophy, however significant it may be in psychology. Explaining away a physicist’s desire to discover
a new particle as a sublimated desire to give
birth would be as absurd as ascribing great significance to the fact that her sister became a
historian because she was given a toy castle as
a child. The reasons behind desires are sometimes important, but this is not the same as reducing all desires to variations on biological
urges.

For more on what you can do with LATEX, check out Extended Features in the Help menu; there are also
plenty of good books and online documents on LATEX.
12 This

feature is only available if latex2html or a similar program is installed on your computer.
By the way, the “X” in LATEX, is pronounced like Scottish “loch” or German “Bach”. It’s because it was originally the Greek
letter “chi”, but it also prevents people from thinking your talking about the stuff condoms are made out of.
13
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Conclusion
You now know just about everything necessary to produce a first-class document with LYX. If you want to
do more (and there is loads more that can be done), try the Tutorial and User’s Guide, both of which can
be found under the Help menu. Have fun, and remember the Golden Rule of LYX:
Don’t worry about what it will look like. Just think about what you want to say, and the
computer will do the rest.
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